PAT (Basic Level) Practice (中文)1028 人口普查 分数 20
题目简介:
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数 N,取值在(0,105];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd
(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
代码长度限制 16 KB; 时间限制 200 ms;内存限制 64 MB。
解析:
#include <iostream>
#include <string>
#include <cstdlib>
#include <vector>
#include <algorithm>
using namespace std;
struct peo{
string name;
int year;
int month;
int day;
peo():
name(""), year(0), month(0), day(0){};
peo(string _name, int _year, int _month, int _day):
name(_name), year(_year), month(_month), day(_day){};
};
bool cmp(peo p1, peo p2){
if(p1.year!=p2.year){
return p1.year<p2.year;
}else if(p1.month!=p2.month){
return p1.month<p2.month;
}else if(p1.day!=p2.day){
return p1.day<p2.day;
}
return true;
}
int main(){
int n;
cin>>n;
vector<peo> v;//如果想使用v(n)来初始化大小,必须自己定义默认构造函数
//我不知到为什么使用vector<peo> v(n)初始化之后,输出的v[0].name是几个空格,而且v.size()是3,没有变大
peo max("", 2014, 9, 6);//最大日期
peo min("", 1814, 9, 6);//最小日期
string name, bir;
int sum=0;
// peo p2("max", 2014, 9, 7);
// peo p3("min", 1814, 9, 5);
// cout<<cmp(p2, max)<<" "<<cmp(min, p3)<<endl;
for(int i=0; i<n; i++){
cin>>name>>bir;
int y=strtod(bir.substr(0, 4).c_str(), nullptr);
int m=strtod(bir.substr(5, 2).c_str(), nullptr);
int d=strtod(bir.substr(8, 2).c_str(), nullptr);
peo p1(name, y, m, d);
if(cmp(p1, max) && cmp(min, p1)){//处在最大,最小之间。
v.push_back(p1);//自动扩容
sum++;//记录总数
}
}
sort(v.begin(), v.end(), cmp);//自定义排序
// for(int i=0; i<v.size(); i++){
// cout<<v[i].name<<" ";
// }
// cout<<endl;
if(!v.empty())//注意v的size,否则引发段错误,意思就是非法访问了内存。
cout<<sum<<" "<<v[0].name<<" "<<v[v.size()-1].name;
else{
cout<<0;
}
return 0;
}